Welcome Forums Bugs Hero Can Walk While A Walk Command Is Executed Reply To: Hero Can Walk While A Walk Command Is Executed

#31814
Marby
Moderator

To remove the impact of this one wasn’t easy. I tried a lot:
– I created another invisible button and created my screenplay there
– I added a says-command before the walks-to-command
– I deleted the NPC and used another NPC. After that, I changed the sprite to the NPC I actually needed for my game.
– I saved the changes and reloaded the game multiple times
None of the changes helped.
Therefore, I started my cutscene from scratch and first tried to let the NPC walk (x=0, y=20) for testing, if the hero meanwhile is still able to walk too while the NPCs walk-command is running. With only the walk command in the screenplay nothing has happend at all (the NPC was standing still), but the engine said that my screenplay is correct! I inserted a:
hero says “Executed!”
at the end of the screenplay. Hereafter, the walk command hasn’t been excecuted, but the text window said “Executed!”. Then I changed my x/y values for the walks-to-command in x=0, y=5. The NPC walked as intended and the arrow keys were deactivated. Because this was the desired behaviour, I instantly saved that version of my game.

That was pretty strange. Fortunatelly, the bug hasn’t returned yet.

0